Kurz gesagt
- CVE-2025-49124 ist eine Schwachstelle (HOCH (CVSS 8.4)) in org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat, org.apache.tomcat:tomcat-catalina.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.36%, höher als bei 29.9% aller Schwachstellen.
- Abhilfe: auf 10.1.42, 11.0.8, 9.0.106 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| org.apache.tomcat.embed:tomcat-embed-core Maven | ≥ 10.1.0, < 10.1.42≥ 11.0.0-M1, < 11.0.8≥ 9.0.23, < 9.0.106
| 10.1.4211.0.89.0.106
|
| org.apache.tomcat:tomcat Maven | ≥ 10.1.0, < 10.1.42≥ 11.0.0-M1, < 11.0.8≥ 9.0.23, < 9.0.106
| 10.1.4211.0.89.0.106
|
| org.apache.tomcat:tomcat-catalina Maven | ≥ 10.1.0, < 10.1.42≥ 11.0.0-M1, < 11.0.8≥ 9.0.23, < 9.0.106
| 10.1.4211.0.89.0.106
|
| tomcat | ≥ 10.1.0, < 10.1.42≥ 11.0.0, < 11.0.8≥ 9.0.23, < 9.0.106
| 10.1.4211.0.89.0.106
|
Description
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
NVD description
Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Weitere Schwachstellen in org.apache.tomcat.embed:tomcat-embed-core
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free