Kurz gesagt
- CVE-2025-54384 ist eine Schwachstelle (MITTEL (CVSS 6.3)) in ckan.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.23%, höher als bei 13.3% aller Schwachstellen.
- Abhilfe: auf 2.11.4, 2.10.9 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.11.0, < 2.11.4< 2.10.9
| 2.11.42.10.9
|
Description
Impact
The helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector.
Patches
This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
NVD description
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free