Kurz gesagt
- CVE-2025-55003 ist eine Schwachstelle (MITTEL (CVSS 5.7)) in github.com/openbao/openbao, openbao (openbao).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.27%, höher als bei 19.0% aller Schwachstellen.
- Abhilfe: auf 2.3.2, 0.0.0-20250807113757-8340a6918f6c oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| github.com/openbao/openbao Go | ≥ 0.1.0, < 2.3.2≥ 0.1.0< 0.0.0-20250807113757-8340a6918f6c
| 2.3.20.0.0-20250807113757-8340a6918f6c
|
| openbao | < 2.3.2
| 2.3.2
|
Description
Impact
OpenBao's Login Multi-Factor Authentication (MFA) system allows enforcing MFA using Time-based One Time Password (TOTP). Due to normalization applied by the underlying TOTP library, codes were accepted which could contain whitespace; this whitespace could bypass internal rate limiting of the MFA method and allow reuse of existing MFA codes.
Patches
OpenBao v2.3.2 will patch this issue.
Workarounds
Use of rate-limiting quotas can limit an attacker's ability to exploit this: https://openbao.org/api-docs/system/rate-limit-quotas/
References
This issue was disclosed to HashiCorp and is the OpenBao equivalent of the following tickets:
NVD description
OpenBao exists to provide a software solution to manage, store, and distribute sensitive data including secrets, certificates, and keys. In versions 2.3.1 and below, OpenBao's Login Multi-Factor Authentication (MFA) system allows enforcing MFA using Time-based One Time Password (TOTP). Due to normalization applied by the underlying TOTP library, codes were accepted which could contain whitespace; this whitespace could bypass internal rate limiting of the MFA method and allow reuse of existing MFA codes. This issue was fixed in version 2.3.2. To work around this, use of rate-limiting quotas can limit an attacker's ability to exploit this: https://openbao.org/api-docs/system/rate-limit-quotas/.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free