Kurz gesagt
- CVE-2025-58758 ist eine Schwachstelle (HOCH (CVSS 7.3)) in datahihi1/tiny-env, tinyenv (datahihi1).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.19%, höher als bei 8.3% aller Schwachstellen.
- Abhilfe: auf 1.0.11, 1.0.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| datahihi1/tiny-env Packagist | ≥ 1.0.9, < 1.0.11< 1.0.3
| 1.0.111.0.3
|
| tinyenv | ≥ 1.0.1, < 1.0.3≥ 1.0.9, < 1.0.11
| 1.0.31.0.11
|
Description
Impact
TinyEnv did not require the .env file to exist when loading environment variables.
This could lead to unexpected behavior where the application silently ignores missing configuration, potentially causing insecure defaults or deployment misconfigurations.
Affected versions:
- 1.0.1 → 1.0.2
- 1.0.9 → 1.0.10
Patches
The issue has been fixed in version 1.0.11.
All users should upgrade to 1.0.11 or later.
Workarounds
As a workaround, users can manually verify the existence of the .env file before initializing TinyEnv, for example:
if (!file_exists(__DIR__ . '/.env')) {
throw new RuntimeException('.env file is missing!');
}
NVD description
TinyEnv is an environment variable loader for PHP applications. In versions 1.0.1, 1.0.2, 1.0.9, and 1.0.10, TinyEnv did not require the `.env` file to exist when loading environment variables. This could lead to unexpected behavior where the application silently ignores missing configuration, potentially causing insecure defaults or deployment misconfigurations. The issue has been fixed in version 1.0.11. All users should upgrade to 1.0.11 or later. As a workaround, users can manually verify the existence of the `.env` file before initializing TinyEnv.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free