Kurz gesagt
- CVE-2025-61622 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in pyfory, pyfury, fory (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 45.1%, höher als bei 98.8% aller Schwachstellen.
- Abhilfe: auf 0.12.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| pyfory PyPI | ≥ 0.12.0, < 0.12.3
| 0.12.3
|
| pyfury PyPI | ≥ 0.1.0, ≤ 0.10.3
| No fix yet |
| fory | ≥ 0.1.0, ≤ 0.10.3≥ 0.12.0, ≤ 0.12.2
| No fix yet |
Description
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of pickle.loads, which is vulnerable to remote code execution.
Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
NVD description
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution.
Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free