| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.kylin:kylin | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-common-server | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-common-service | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-core-common | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-core-metadata | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-ops-server | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| org.apache.kylin:kylin-server | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
| kylin | ≥ 4.0.0, < 5.0.3 | 5.0.3 |
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin.
This issue affects Apache Kylin: from 4.0.0 through 5.0.2. You are fine as long as the Kylin's system and project admin access is well protected.
Users are recommended to upgrade to version 5.0.3, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free