Kurz gesagt
- CVE-2025-62374 ist eine Schwachstelle (MITTEL (CVSS 6.4)) in parse.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.41%, höher als bei 35.3% aller Schwachstellen.
- Abhilfe: auf 7.0.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| parse npm | < 7.0.0
| 7.0.0
|
Description
Summary
Prototype pollution capabilities on various APIs.
Details
Injection of malicious payload allows attacker to remotely execute arbitrary code. Parse.Object and internal APIs are affected, specifically:
ParseObject.fromJSON
ParseObject.pin
ParseObject.registerSubclass
ObjectStateMutations (internal)
encode/decode (internal)
PoC
Demonstrative tests added as part of the fix.
References
NVD description
Parse Javascript SDK provides access to the powerful Parse Server backend from your JavaScript app. Prior to 7.0.0, injection of malicious payload allows attacker to remotely execute arbitrary code. ParseObject.fromJSON, ParseObject.pin, ParseObject.registerSubclass, ObjectStateMutations (internal), and encode/decode (internal) are affected. This vulnerability is fixed in 7.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free