Kurz gesagt
- CVE-2025-62707 ist eine Schwachstelle (HOCH (CVSS 7.5)) in pypdf, pypdf (pypdf project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.44%, höher als bei 38.6% aller Schwachstellen.
- Abhilfe: auf 6.1.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.1.3
| 6.1.3
|
| pypdf | < 6.1.3
| 6.1.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires parsing the content stream of a page which has an inline image using the DCTDecode filter.
Patches
This has been fixed in pypdf==6.1.3.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3501.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires parsing the content stream of a page which has an inline image using the DCTDecode filter. This has been fixed in pypdf version 6.1.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free