Kurz gesagt
- CVE-2025-8396 ist eine Schwachstelle (MITTEL (CVSS 6.9)) in go.temporal.io/server.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.39%, höher als bei 33.1% aller Schwachstellen.
- Abhilfe: auf 1.27.3, 1.28.1, 1.26.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| go.temporal.io/server Go | ≥ 1.27.0-126.0, < 1.27.3≥ 1.28.0-129.0, < 1.28.1< 1.26.3
| 1.27.31.28.11.26.3
|
Description
Insufficiently specific bounds checking on authorization header could lead to denial of service in the Temporal server on all platforms due to excessive memory allocation. This issue affects all platforms and versions of OSS Server prior to 1.26.3, 1.27.3, and 1.28.1 (i.e., fixed in 1.26.3, 1.27.3, and 1.28.1 and later). Temporal Cloud services are not impacted.
NVD description
Insufficiently specific bounds checking on authorization header could lead to denial of service in the Temporal server on all platforms due to excessive memory allocation.This issue affects all platforms and versions of OSS Server prior to 1.26.3, 1.27.3, and 1.28.1 (i.e., fixed in 1.26.3, 1.27.3, and 1.28.1 and later). Temporal Cloud services are not impacted.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free