Kurz gesagt
- CVE-2026-101915 ist eine Schwachstelle (NIEDRIG (CVSS 3.7)) in @grpc/grpc-js.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.25%, höher als bei 16.5% aller Schwachstellen.
- Abhilfe: auf 1.14.5, 1.13.6 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| @grpc/grpc-js npm | ≥ 1.14.0, < 1.14.5< 1.13.6
| 1.14.51.13.6
|
Description
Impact
If an application method handler crashes, the error message is included in the status message sent to the client. This can leak to the client any sensitive data that may be included in the error message. This impacts anyone using @grpc/grpc-js to run servers.
Patches
This vulnerability is fixed in 1.13.6 and 1.14.5.
Workarounds
This can be avoided by using a top-level error handler in method handlers to strip out sensitive error information.
NVD description
@grpc/grpc-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.13.6 and 1.14.5, when an application method handler throws an uncaught error, the server includes its error message in the status message sent to the client. The thrown error message is transmitted to the client, causing sensitive information disclosure when the message contains sensitive data. This issue is fixed in versions 1.13.6 and 1.14.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free