Kurz gesagt
- CVE-2026-105849 ist eine Schwachstelle (HOCH (CVSS 8.3)) in payload (payloadcms), payload.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.30%, höher als bei 22.8% aller Schwachstellen.
- Abhilfe: auf 3.90.0, 4.0.0-canary.34 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| payload | = 4.0.0≥ 3.0.0, < 3.90.0
| 3.90.0
|
| payload npm | ≥ 3.0.0, < 3.90.0≥ 4.0.0-canary.0, < 4.0.0-canary.34
| 3.90.04.0.0-canary.34
|
Description
Impact
Users with read access to other user documents could access their active API keys. An exposed key grants the target account’s permissions until rotated or disabled.
You are affected if:
- An authentication collection enables
useAPIKey.
- Users have read access to other user documents containing active API keys.
Patches
Users should upgrade payload packages to >= 3.90.0 or >= 4.0.0-canary.34.
Workarounds
Disable useAPIKey or restrict users to reading only their own authentication document. Rotate any API key that may have been exposed.
NVD description
Payload is a free and open source headless content management system. In versions from 3.0.0 before 3.90.0 and canary versions before 4.0.0-canary.34, users with ordinary read access to other authentication documents in a collection with useAPIKey enabled can obtain active API keys and exercise the target accounts' permissions until those keys are rotated or disabled. This issue is fixed in versions 3.90.0 and 4.0.0-canary.34.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free