Kurz gesagt
- CVE-2026-106462 ist eine Schwachstelle (MITTEL (CVSS 6.4)) in backstage (linuxfoundation), backstage/plugin-scaffolder-backend (linuxfoundation), backstage/plugin-scaffolder-backend-module-azure (linuxfoundation).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.17%, höher als bei 6.5% aller Schwachstellen.
- Abhilfe: auf 1.54.6, 0.11.10, 0.2.25, 0.3.10 oder neuer aktualisieren.
Description
Impact
Scaffolder actions that interact with source control systems may not consistently enforce the intended credential boundaries under certain configurations. An authenticated user could perform operations with broader access than intended.
Patches
@backstage/plugin-scaffolder-backend version 4.1.0
@backstage/plugin-scaffolder-backend-module-azure version 0.2.25
@backstage/plugin-scaffolder-backend-module-bitbucket-cloud version 0.3.10
@backstage/plugin-scaffolder-backend-module-bitbucket-server version 0.2.25
@backstage/plugin-scaffolder-backend-module-github version 0.9.13
@backstage/plugin-scaffolder-backend-module-gitlab version 0.11.10
The fix introduces a new configuration option that enforces user-provided credentials for supported SCM actions. The new behavior is opt-in for compatibility. After upgrading, set:
scaffolder:
requireScmUserCredentials: true
Before enabling this setting, review and update your templates as described in the software templates documentation referred to below.
Workarounds
If you cannot upgrade and enable the setting immediately:
- Restrict who can create Scaffolder tasks and which templates they can execute.
- Limit SCM integration credentials to the minimum repository read and mutation permissions required.
- Remove integration credentials for SCM hosts where all required operations can use explicitly supplied user tokens.
NVD description
Backstage is an open framework for building developer portals. Prior to 1.54.6, scaffolder source-control actions may not consistently enforce intended credential boundaries. An authenticated user could cause an affected action to fall back to broader integration credentials and perform operations with more access than intended. This issue is fixed in 1.54.6 when operators also enable scaffolder.requireScmUserCredentials after upgrading.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free