| Package | Affected versions | Patched versions |
|---|---|---|
| undici | ≥ 7.0.0, < 7.24.0< 6.24.0 | 7.24.06.24.0 |
| undici | ≥ 7.0.0, < 7.24.0< 6.24.0 | 7.24.06.24.0 |
When an application passes user-controlled input to the upgrade option of client.request(), an attacker can inject CRLF sequences (\r\n) to:
The vulnerability exists because undici writes the upgrade value directly to the socket without validating for invalid header characters:
// lib/dispatcher/client-h1.js:1121
if (upgrade) {
header += `connection: upgrade\r\nupgrade: ${upgrade}\r\n`
}
Patched in the undici version v7.24.0 and v6.24.0. Users should upgrade to this version or later.
Sanitize the upgrade option string before passing to undici:
function sanitizeUpgrade(value) {
if (/[\r\n]/.test(value)) {
throw new Error('Invalid upgrade value')
}
return value
}
client.request({
upgrade: sanitizeUpgrade(userInput)
})
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free