| Package | Affected versions | Patched versions |
|---|---|---|
| saleor | ≥ 3.2.0, < 3.20.110≥ 3.21.0, < 3.21.45≥ 3.22.0, < 3.22.29 | 3.20.1103.21.453.22.29 |
Saleor is an e-commerce platform. Versions 3.2.0 through 3.20.109, 3.21.0-a.0 through 3.21.44 and 3.22.0-a.0 through 3.22.28 have a n Insecure Direct Object Reference (IDOR) vulnerability that allows unauthenticated actors to extract sensitive information in plain text. Orders created before Saleor 3.2.0 could have PIIs exfiltrated. The issue has been patched in Saleor versions: 3.22.29, 3.21.45, and 3.20.110. To workaround, temporarily block non-staff users from fetching order information (the order() GraphQL query) using a WAF.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free