Kurz gesagt
- CVE-2026-24688 ist eine Schwachstelle (MITTEL (CVSS 4.3)) in pypdf, pypdf (pypdf project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.45%, höher als bei 38.7% aller Schwachstellen.
- Abhilfe: auf 6.6.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.6.2
| 6.6.2
|
| pypdf | < 6.6.2
| 6.6.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks.
Patches
This has been fixed in pypdf 6.6.2.
Workarounds
If projects cannot upgrade yet, consider applying the changes from PR #3610.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses an infinite loop vulnerability that is present in versions prior to 6.6.2 can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks. This has been fixed in pypdf 6.6.2. If projects cannot upgrade yet, consider applying the changes from PR #3610 manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free