Kurz gesagt
- CVE-2026-25140 ist eine Schwachstelle (HOCH (CVSS 7.5)) in chainguard.dev/apko, apko (chainguard).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.41%, höher als bei 35.0% aller Schwachstellen.
- Abhilfe: auf 1.1.1 oder neuer aktualisieren.
Description
apko affected by potential unbounded resource consumption in expandapk.ExpandApk on attacker-controlled .apk streams in chainguard.dev/apko
NVD description
apko allows users to build and publish OCI container images built from apk packages. From version 0.14.8 to before 1.1.1, an attacker who controls or compromises an APK repository used by apko could cause resource exhaustion on the build host. The ExpandApk function in pkg/apk/expandapk/expandapk.go expands .apk streams without enforcing decompression limits, allowing a malicious repository to serve a small, highly-compressed .apk that inflates into a large tar stream, consuming excessive disk space and CPU time, causing build failures or denial of service. This issue has been patched in version 1.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free