| Package | Affected versions | Patched versions |
|---|---|---|
| mlflow | < 3.10.0< 3.11.0rc0 | 3.10.03.11.0rc0 |
| mlflow | ≤ 3.10.1 |
A vulnerability in MLflow versions <=3.10.1.dev0 allows unauthorized access to multipart upload (MPU) endpoints when the --serve-artifacts mode is enabled. The authorization logic does not enforce resource-level permission checks for /mlflow-artifacts/mpu/* endpoints, enabling attackers to overwrite artifacts belonging to other users. This can lead to unauthorized cross-user writes, model supply chain poisoning, and arbitrary code execution when compromised models are loaded. The issue is resolved in version 3.10.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free