Kurz gesagt
- CVE-2026-27121 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in svelte (svelte), svelte.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.22%, höher als bei 12.6% aller Schwachstellen.
- Abhilfe: auf 5.51.5 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 5.51.5
| 5.51.5
|
| svelte npm | < 5.51.5
| 5.51.5
|
Description
Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers.
NVD description
svelte performance oriented web framework. Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims' browsers. This vulnerability is fixed in 5.51.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free