Kurz gesagt
- CVE-2026-27194 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in dtale, d-tale (man).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.79%, höher als bei 56.3% aller Schwachstellen.
- Abhilfe: auf 3.20.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| dtale PyPI | < 3.20.0
| 3.20.0
|
| d-tale | ≤ 3.19.1
| No fix yet |
Description
Impact
Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server.
Patches
Users should upgrade to version 3.20.0.
Workarounds
There are no workarounds for versions < 3.20.0
NVD description
D-Tale is a visualizer for pandas data structures. Versions prior to 3.20.0 are vulnerable to Remote Code Execution through the /save-column-filter endpoint. Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. This issue has been fixed in version 3.20.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free