Kurz gesagt
- CVE-2026-31858 ist eine Schwachstelle (HOCH (CVSS 8.8)) in craftcms/cms, craft cms (craftcms).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.36%, höher als bei 30.2% aller Schwachstellen.
- Abhilfe: auf 5.9.9 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| craftcms/cms Packagist | ≥ 5.0.0-RC1, < 5.9.9
| 5.9.9
|
| craft cms | = 5.0.0≥ 5.0.1, < 5.9.9
| 5.9.9
|
Description
The ElementSearchController::actionSearch() endpoint is missing the unset() protection that
was added to ElementIndexesController in GHSA-2453-mppf-46cj.
The exact same SQL injection vulnerability (including criteria[orderBy], the original advisory vector) works on this controller because the fix was never applied to it.
Any authenticated control panel user (no admin required) can inject arbitrary SQL via criteria[where],
criteria[orderBy], or other query properties, and extract the full database contents via boolean-based blind injection.
Users should update to the patched 5.9.9 release to mitigate the issue.
NVD description
Craft is a content management system (CMS). The ElementSearchController::actionSearch() endpoint is missing the unset() protection that was added to ElementIndexesController in CVE-2026-25495. The exact same SQL injection vulnerability (including criteria[orderBy], the original advisory vector) works on this controller because the fix was never applied to it. Any authenticated control panel user (no admin required) can inject arbitrary SQL via criteria[where], criteria[orderBy], or other query properties, and extract the full database contents via boolean-based blind injection. Users should update to the patched 5.9.9 release to mitigate the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free