Kurz gesagt
- CVE-2026-31987 ist eine Schwachstelle (HOCH (CVSS 7.5)) in apache-airflow, airflow (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.74%, höher als bei 54.6% aller Schwachstellen.
- Abhilfe: auf 3.2.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
| airflow | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
Description
JWT Tokens used by tasks were exposed in logs. This could allow UI users to act as Dag Authors.
Users are advised to upgrade to Airflow version that contains fix.
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
NVD description
JWT Tokens used by tasks were exposed in logs. This could allow UI users to act as Dag Authors.
Users are advised to upgrade to Airflow version that contains fix.
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free