Apache Tomcat Missing Encryption of Sensitive Data Vulnerability. Actively exploited: CISA added this vulnerability to its Known Exploited Vulnerabilities catalog on 04/08/2026. Patch affected systems as an emergency.
| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat:tomcat | ≥ 10.1.53, < 10.1.54≥ 11.0.20, < 11.0.21≥ 9.0.116, < 9.0.117 | 10.1.5411.0.219.0.117 |
| org.apache.tomcat:tomcat-tribes | ≥ 10.1.53, < 10.1.54≥ 11.0.20, < 11.0.21≥ 9.0.116, < 9.0.117 | 10.1.5411.0.219.0.117 |
| tomcat | = 10.1.53= 11.0.20= 9.0.116 | |
| jboss web server | = 7.0.0 |
Missing Encryption of Sensitive Data vulnerability in Apache Tomcat due to the fix for CVE-2026-29146 allowing the bypass of the EncryptInterceptor.
This issue affects Apache Tomcat: 11.0.20, 10.1.53, 9.0.116.
Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free