Kurz gesagt
- CVE-2026-40963 ist eine Schwachstelle (NIEDRIG (CVSS 3.1)) in apache-airflow, airflow (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.48%, höher als bei 41.2% aller Schwachstellen.
- Abhilfe: auf 3.2.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.2.2
| 3.2.2
|
| airflow | ≥ 3.0.0, < 3.2.2
| 3.2.2
|
Description
The structure_data endpoint in the Airflow UI returned external dependency graph nodes for linked Dags without checking whether the caller had read permission on those linked Dags. An authenticated UI/API user authorized for one Dag could enumerate linked Dag IDs and dependency metadata for other Dags they were not authorized to read. Affects deployments that rely on per-Dag read scoping to keep Dag dependency topology private across teams. Users are advised to upgrade to apache-airflow 3.2.2 or later.
NVD description
The structure_data endpoint in the Airflow UI returned external dependency graph nodes for linked Dags without checking whether the caller had read permission on those linked Dags. An authenticated UI/API user authorized for one Dag could enumerate linked Dag IDs and dependency metadata for other Dags they were not authorized to read. Affects deployments that rely on per-Dag read scoping to keep Dag dependency topology private across teams. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free