| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.activemq:activemq-web | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
| org.apache.activemq:apache-activemq | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
| activemq | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
| activemq web | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web.
The MessageServlet in the ActiveMQ web console API copies every JMS message property into an HTTP response header without any validation. This can allow overwriting and injecting security headers by setting them on JMS messages that are returned by the servlet.
This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ Web: before 5.19.7, from 6.0.0 before 6.2.6.
Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue. The MessageServlet has now been deprecated and disabled by default.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free