Kurz gesagt
- CVE-2026-42309 ist eine Schwachstelle (MITTEL (CVSS 5.5)) in pillow, pillow (python).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.13%, höher als bei 2.8% aller Schwachstellen.
- Abhilfe: auf 12.2.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | ≥ 11.2.1, < 12.2.0
| 12.2.0
|
| pillow | ≥ 11.2.1, < 12.2.0
| 12.2.0
|
Description
Passing nested lists as coordinates to APIs that accept coordinates such as ImagePath.Path, ImageDraw.ImageDraw.polygon and ImageDraw.ImageDraw.line could cause a heap buffer overflow, as nested lists were recursively unpacked beyond the allocated buffer. Coordinate lists are now validated to contain exactly two numeric coordinates. This was introduced in Pillow 11.2.1.
NVD description
Pillow is a Python imaging library. From version 11.2.1 to before version 12.2.0, passing nested lists as coordinates to APIs that accept coordinates such as ImagePath.Path, ImageDraw.ImageDraw.polygon and ImageDraw.ImageDraw.line could cause a heap buffer overflow, as nested lists were recursively unpacked beyond the allocated buffer. Coordinate lists are now validated to contain exactly two numeric coordinates. This issue has been patched in version 12.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free