| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.syncope.core:syncope-core-spring | ≥ 3.0.0-M0, ≤ 3.0.16≥ 4.0.0-M0, < 4.0.6≥ 4.1.0-M0, < 4.1.1 | 4.0.64.1.1 |
| syncope | = 4.1.0≥ 3.0.0, ≤ 3.0.16≥ 4.0.0, < 4.0.6 | 4.0.6 |
Improper Isolation or Compartmentalization vulnerability in Apache Syncope.
An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer.
This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0.
Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free