Kurz gesagt
- CVE-2026-44161 ist eine Schwachstelle (HOCH (CVSS 7.2)) in fluentd, fluentd (fluentd).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.44%, höher als bei 38.4% aller Schwachstellen.
- Abhilfe: auf 1.19.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| fluentd RubyGems | < 1.19.3
| 1.19.3
|
| fluentd | < 1.19.3
| 1.19.3
|
Description
The out_http output plugin allows the use of placeholders (such as ${tag}) in the endpoint configuration parameter.
It was discovered that if the placeholder value is derived from untrusted user input, an attacker can maliciously control the destination hostname of the outbound HTTP requests made by Fluentd.
Impact
This vulnerability allows for a Server-Side Request Forgery (SSRF) attack.
An unauthenticated attacker can force the Fluentd node to send HTTP requests to arbitrary internal services. This can lead to unauthorized access to internal APIs, data exfiltration, or the compromise of cloud metadata endpoints (e.g., AWS IMDS 169.254.169.254).
Patches
v1.19.3
Workarounds
If an immediate upgrade is not possible, users are strongly advised to apply the following mitigations:
-
Avoid Dynamic Hostnames
- Do not use the placeholder in the endpoint parameter as hostname.
-
Restrict Network Access
- Use firewall rules (e.g., iptables, AWS Security Groups) to block the Fluentd node from accessing sensitive internal IP addresses, specifically the cloud provider's metadata service and other internal microservices that Fluentd does not explicitly need to access.
-
Restrict allowed hosts
- Inject filter to accept allowed hosts in placeholders explicitly if possible.
NVD description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free