Kurz gesagt
- CVE-2026-54259 ist eine Schwachstelle (MITTEL (CVSS 4.3)) in wagtail, wagtail (torchbox).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.27%, höher als bei 19.3% aller Schwachstellen.
- Abhilfe: auf 7.3.3, 7.4.2, 7.0.8 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| wagtail PyPI | ≥ 7.1, < 7.3.3≥ 7.4, < 7.4.2< 7.0.8
| 7.3.37.4.27.0.8
|
| wagtail | ≥ 7.1, < 7.3.3≥ 7.4, < 7.4.2< 7.0.8
| 7.3.37.4.27.0.8
|
Description
Impact
The Documents and Images chooser's chosen endpoint incorrectly listed items for which the user has not been granted choose permission. A user with access to the Wagtail admin could see the filename and name and URLs of documents and images in those collections.
The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patches
Patched versions have been released as Wagtail 7.0.8, 7.3.3, 7.4.2.
Workarounds
N/A
Acknowledgements
Many thanks to @harshakshit for reporting this issue.
For more information
If you have any questions or comments about this advisory:
NVD description
Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, the Documents and Images chooser's chosen endpoint incorrectly listed items for which the user has not been granted choose permission. A user with access to the Wagtail admin could see the filename and name and URLs of documents and images in those collections. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free