Kurz gesagt
- CVE-2026-55170 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in github.com/openfga/openfga, helm charts (openfga), openfga (openfga).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.34%, höher als bei 27.4% aller Schwachstellen.
- Abhilfe: auf 1.18.0, 0.3.9 oder neuer aktualisieren.
Description
Description
In OpenFGA, when MySQL is being used as the datastore, two distinct check requests can return the same response.
Preconditions
This applies if the following preconditions are met:
- You run OpenFGA with MySQL as the datastore
- Your authorization decisions rely on case-sensitive user strings.
Fix
Upgrade to OpenFGA 1.18.0 or greater.
Acknowledgements
OpenFGA would like to thank @sahajamoth for the detailed report.
NVD description
OpenFGA is an authorization/permission engine built for developers. Prior to 1.18.0, when MySQL is being used as the datastore and authorization decisions rely on case-sensitive user strings, the tuple, changelog, and authorization_model identifier columns can compare case-distinct values such as user:Alice and user:alice as equivalent, causing two distinct check requests to return the same response. This issue is fixed in 1.18.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free