Kurz gesagt
- CVE-2026-86996 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in n8n (n8n), n8n.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.29%, höher als bei 22.1% aller Schwachstellen.
- Abhilfe: auf 2.38.2, 2.37.7 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| n8n | ≥ 2.38.0, < 2.38.2< 2.37.7
| 2.38.22.37.7
|
| n8n npm | ≥ 2.38.0, < 2.38.2< 2.37.7
| 2.38.22.37.7
|
Description
Impact
A workflow's "This workflow can be called by" setting was enforced by the Execute Workflow node but was not consulted when the same workflow was attached to an Agent as a tool. A user who could build an Agent could therefore call a workflow that its owner had restricted, and read back what it returned. The patch applies the sub-workflow caller policy on the Agent tool path.
Patches
The issue has been fixed in n8n versions 2.37.7 and 2.38.2. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Restrict n8n instance access to fully trusted users only.
- Audit workflows attached as Agent tools and review their caller policy settings.
- Remove sensitive workflows from Agent tool configurations until the instance is patched.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to 2.37.7 and 2.38.2, the workflow setting named This workflow can be called by was enforced by the Execute Workflow node but not when a workflow was attached to an Agent as a tool. A user able to build an Agent could invoke a restricted workflow and read its returned data. The affected path is packages/cli/src/modules/agents/tools/workflow-tool-factory.ts, where executeWorkflow omitted SubworkflowPolicyChecker.checkForProject. This issue is fixed in versions 2.37.7 and 2.38.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free