| Package | Affected versions | Patched versions |
|---|---|---|
| wss4j | ≥ 3.0.0, < 3.0.6≥ 4.0.0, < 4.0.2< 2.4.4 | 3.0.64.0.22.4.4 |
An authentication bypass in the DOM security processor in Apache WSS4J allows unauthenticated remote attackers to forge authenticated SOAP messages via a crafted unsigned SAML sender-vouches assertion containing an attacker-controlled key. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free