| Package | Affected versions | Patched versions |
|---|---|---|
| org.opensearch.plugin:opensearch-security | ≥ 1.0.0, < 2.19.4.0≥ 3.0.0, < 3.2.0.0 | 2.19.4.03.2.0.0 |
A flaw was identified in the OpenSearch Security plugin's handling of index rollover requests. When a rollover request included an explicit target index name, the security plugin did not properly evaluate access control permissions against the target index. This could allow a user with rollover permissions on a source index to create a new index with a name they are not authorized to use.
A user with indices:admin/rollover permission on a source index pattern could roll over to a target index name outside their authorized index patterns. This is limited to index creation via the rollover API and requires the user to already have rollover privileges on the source index.
This issue is fixed in OpenSearch 2.19.4 and 3.2.0
Grant the indices:admin/rollover permission only to fully trusted users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free