CVE search
Every published CVE plus open-source advisories (NVD, OSV, GitHub), with CVSS, EPSS and whether it is being exploited in the wild (CISA KEV). Updated every few hours. Our scans match these against the technologies they detect.
Every published CVE plus open-source advisories (NVD, OSV, GitHub), with CVSS, EPSS and whether it is being exploited in the wild (CISA KEV). Updated every few hours. Our scans match these against the technologies they detect.
| MITTEL5.9 |
A zone transition from NSEC to NSEC3 might trigger an internal inconsistency and cause a denial of service. |
| 22/04/2026 |
| CVE-2026-33260 | HOCH7.5 | An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default. | 22/04/2026 |
| CVE-2026-33259 | MITTEL5.0 | Having many concurrent transfers of the same RPZ can lead to inconsistent RPZ data, use after free and/or a crash of the recursor. Normally concurrent transfers of the same RPZ zone can only occur with a malfunctioning RPZ provider. | 22/04/2026 |
| CVE-2026-33258 | HOCH7.5 | By publishing and querying a crafted zone an attacker can cause allocation of large entries in the negative and aggressive NSEC(3) caches. | 22/04/2026 |
| CVE-2026-33257 | HOCH7.5 | An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default. | 22/04/2026 |
| CVE-2026-33256 | HOCH7.5 | An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default. | 22/04/2026 |
| CVE-2026-24027 | MITTEL5.3 | Crafted zones can lead to increased incoming network traffic. | 09/02/2026 |
| CVE-2026-0398 | MITTEL5.3 | Crafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in Recursor. | 09/02/2026 |
| CVE-2025-59024 | MITTEL6.5 | Crafted delegations or IP fragments can poison cached delegations in Recursor. | 09/02/2026 |
| CVE-2025-59023 | HOCH8.2 | Crafted delegations or IP fragments can poison cached delegations in Recursor. | 09/02/2026 |
| CVE-2025-59030 | HOCH7.5 | An attacker can trigger the removal of cached records by sending a NOTIFY query over TCP. | 09/12/2025 |
| CVE-2025-59029 | MITTEL5.3 | An attacker can trigger an assertion failure by requesting crafted DNS records, waiting for them to be inserted into the records cache, then send a query with qtype set to ANY. | 09/12/2025 |
| CVE-2023-50868 | HOCH7.5 | The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorit | 14/02/2024 |
| CVE-2023-50387 | HOCH7.5 | Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol | 14/02/2024 |
| CVE-2023-26437 | MITTEL5.3 | Denial of service vulnerability in PowerDNS Recursor allows authoritative servers to be marked unavailable.This issue affects Recursor: through 4.6.5, through 4.7.4 , through 4.8.3. | 04/04/2023 |
| CVE-2023-22617 | HOCH7.5 | A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS query that retrieves DS records for a misconfigured domain, because QName minimization is used in QM fallback mode. This is fixed in 4.8.1. | 21/01/2023 |
| CVE-2022-37428 | MITTEL6.5 | PowerDNS Recursor up to and including 4.5.9, 4.6.2 and 4.7.1, when protobuf logging is enabled, has Improper Cleanup upon a Thrown Exception, leading to a denial of service (daemon crash) via a DNS query that leads to an answer with specific properties. | 23/08/2022 |