En resumen
- CVE-2015-1369 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a sequelize (sequelize project), sequelize.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.1%, mayor que el 81.8% de las vulnerabilidades.
- Solución: actualizar a 2.0.0-rc8 o posterior.
| Package | Affected versions | Patched versions |
|---|
| sequelize | ≤ 2.0.0
| No fix yet |
| sequelize npm | < 2.0.0-rc8
| 2.0.0-rc8
|
Description
Versions 2.0.0-rc-7 and earlier of sequelize are affected by a SQL injection vulnerability when user input is passed into the order parameter.
Proof of Concept
Test.findAndCountAll({
where: { id :1 },
order : [['id', 'UNTRUSTED USER INPUT']]
})
Recommendation
Update to version 2.0.0-rc8 or later
NVD description
SQL injection vulnerability in Sequelize before 2.0.0-rc7 for Node.js allows remote attackers to execute arbitrary SQL commands via the order parameter.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free