En resumen
- CVE-2015-5654 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a dojo (dojotoolkit), dojo.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.2%, mayor que el 82.7% de las vulnerabilidades.
- Solución: actualizar a 1.9.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| dojo | ≤ 1.1.1
| No fix yet |
| dojo npm | < 1.9.1
| 1.9.1
|
Description
Versions of dojo prior to 1.2.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize HTML code in user-controlled input, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 1.2.0 or later.
NVD description
Cross-site scripting (XSS) vulnerability in Dojo Toolkit before 1.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free