En resumen
- CVE-2015-9243 es una vulnerabilidad MEDIO (CVSS 5.9) que afecta a hapi (hapijs), hapi.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.0%, mayor que el 63.5% de las vulnerabilidades.
- Solución: actualizar a 11.1.4 o posterior.
| Package | Affected versions | Patched versions |
|---|
| hapi | < 11.1.4
| 11.1.4
|
| hapi npm | < 11.1.4
| 11.1.4
|
Description
Versions of hapi prior to 11.1.4 are affected by a vulnerability that causes route-level CORS configuration to override connection-level or server-level CORS defaults. This may result in a situation where CORS permissions are less restrictive than intended.
Recommendation
Update hapi to version 11.1.4 or later.
NVD description
When server level, connection level or route level CORS configurations in hapi node module before 11.1.4 are combined and when a higher level config included security restrictions (like origin), a higher level config that included security restrictions (like origin) would have those restrictions overridden by less restrictive defaults (e.g. origin defaults to all origins `*`).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free