En resumen
- CVE-2016-10524 es una vulnerabilidad ALTO (CVSS 8.2) que afecta a i18n-node-angular (i18n-node-angular project), i18n-node-angular.
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.79%, mayor que el 56.5% de las vulnerabilidades.
- Solución: actualizar a 1.4.0 o posterior.
Description
Versions of i18n-node-angular prior to 1.4.0 are affected by denial of service and cross-site scripting vulnerabilities. The vulnerabilities exist in a REST endpoint that was created for development purposes, but was not disabled in production in affected versions.
Recommendation
Update to version 1.4.0 or later.
NVD description
i18n-node-angular is a module used to interact between i18n and angular without using additional resources. A REST API endpoint that is used for development in i18n-node-angular before 1.4.0 was not disabled in production environments a malicious user could fill up the server causing a Denial of Service or content injection.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free