En resumen
- CVE-2016-10575 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a kindlegen (hakatashi), kindlegen.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.7% de las vulnerabilidades.
- Solución: actualizar a 1.1.0 o posterior.
Description
Affected versions of kindlegen insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running kindlegen.
Recommendation
Update to version 1.1.0 or greater.
NVD description
Kindlegen is a simple Node.js wrapper of the official kindlegen program. Kindlegen versions before 1.1.0 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free