En resumen
- CVE-2016-10582 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a closurecompiler (closurecompiler project), closurecompiler.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 76.7% de las vulnerabilidades.
- Aún no hay una versión corregida: sigue el aviso del fabricante en Referencias.
Description
Affected versions of closurecompiler insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running closurecompiler.
Recommendation
Update to version 1.6.1 or later.
NVD description
closurecompiler is a Closure Compiler for node.js. closurecompiler downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free