En resumen
- CVE-2016-10602 es una vulnerabilidad ALTO (CVSS 8.1) que afecta a haxe (haxe), haxe.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 76.7% de las vulnerabilidades.
- Solución: actualizar a 5.0.10 o posterior.
| Package | Affected versions | Patched versions |
|---|
| haxe | ≤ 5.0.10
| No fix yet |
| haxe npm | < 5.0.10
| 5.0.10
|
Description
Affected versions of haxe insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running haxe.
Recommendation
Update to version 5.0.10 or later.
NVD description
haxe is a cross-platform toolkit haxe downloads zipped resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested zip file with an attacker controlled zip file if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free