En resumen
- CVE-2016-20018 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a knex (knexjs), knex.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.1%, mayor que el 66.3% de las vulnerabilidades.
- Solución: actualizar a 2.4.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| knex | ≤ 2.3.0
| No fix yet |
| knex npm | < 2.4.0
| 2.4.0
|
Description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query. This vulnerability has been fixed in version 2.4.0.
NVD description
Knex Knex.js through 2.3.0 has a limited SQL injection vulnerability that can be exploited to ignore the WHERE clause of a SQL query.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free