En resumen
- CVE-2017-1001002 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a math.js (mathjs), mathjs.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.4%, mayor que el 83.8% de las vulnerabilidades.
- Solución: actualizar a 3.17.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| math.js | ≤ 3.17.0
| No fix yet |
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Recommendation
Update to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free