En resumen
- CVE-2017-1001003 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a mathjs (mathjs project), mathjs.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.2% de las vulnerabilidades.
- Solución: actualizar a 3.17.0 o posterior.
| Package | Affected versions | Patched versions |
|---|
| mathjs | < 3.17.0
| 3.17.0
|
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.
Recommendation
Upgrade to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free