| Package | Affected versions | Patched versions |
|---|---|---|
| openssl | < 2.0.0 | 2.0.0 |
| ruby | = 2.2.0= 2.2.1= 2.2.2= 2.2.3= 2.2.4= 2.2.5= 2.2.6= 2.2.7= 2.3.0= 2.3.1= 2.3.2= 2.3.3= 2.3.4= 2.4.0= 2.4.1 |
The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string. The openssl gem that contains this module is patched in version 2.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free