En resumen
- CVE-2017-16031 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a socket.io (socket), socket.io.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.0%, mayor que el 80.4% de las vulnerabilidades.
- Solución: actualizar a 0.9.7 o posterior.
| Package | Affected versions | Patched versions |
|---|
| socket.io | ≤ 0.9.6
| No fix yet |
| socket.io npm | < 0.9.7
| 0.9.7
|
Description
Affected versions of socket.io depend on Math.random() to create socket IDs, and therefore the IDs are predictable. With enough information on prior IDs, an attacker may be able to guess the socket ID and gain access to socket.io servers without authorization.
Recommendation
Update to v0.9.7 or later.
NVD description
Socket.io is a realtime application framework that provides communication via websockets. Because socket.io 0.9.6 and earlier depends on `Math.random()` to create socket IDs, the IDs are predictable. An attacker is able to guess the socket ID and gain access to socket.io servers, potentially obtaining sensitive information.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free