En resumen
- CVE-2017-16114 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a marked (marked project), marked.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.7%, mayor que el 77.7% de las vulnerabilidades.
- Solución: actualizar a 0.3.9 o posterior.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.9
| 0.3.9
|
| marked npm | < 0.3.9
| 0.3.9
|
Description
Affected versions of marked are vulnerable to a regular expression denial of service.
The amplification in this vulnerability is significant, with 1,000 characters resulting in the event loop being blocked for around 6 seconds.
Recommendation
Update to version 0.3.9 or later.
NVD description
The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free