En resumen
- CVE-2017-16118 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a forwarded (forwarded project), forwarded.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.9%, mayor que el 79.3% de las vulnerabilidades.
- Solución: actualizar a 0.1.2 o posterior.
Description
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later
NVD description
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free