En resumen
- CVE-2017-16138 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a mime (mime project), mime.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.1%, mayor que el 82.0% de las vulnerabilidades.
- Solución: actualizar a 2.0.3, 1.4.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| mime | ≥ 2.0.1, < 2.0.3< 1.4.1
| 2.0.31.4.1
|
| mime npm | ≥ 2.0.0, < 2.0.3< 1.4.1
| 2.0.31.4.1
|
Description
Affected versions of mime are vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.
Recommendation
Update to version 2.0.3 or later.
NVD description
The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free