En resumen
- CVE-2017-16151 es una vulnerabilidad CRÍTICO (CVSS 9.8) que afecta a electron (electronjs), electron.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.7%, mayor que el 85.8% de las vulnerabilidades.
- Solución: actualizar a 1.7.8, 1.6.14 o posterior.
| Package | Affected versions | Patched versions |
|---|
| electron | < 1.7.8
| 1.7.8
|
| electron npm | ≥ 1.7.0, < 1.7.8< 1.6.14
| 1.7.81.6.14
|
Description
Affected versions of ElectronJS are susceptible to a remote code execution vulnerability that occurs when an affected application access remote content, even if the sandbox option is enabled.
Recommendation
Update to electron version 1.7.8 or later.
NVD description
Based on details posted by the ElectronJS team; A remote code execution vulnerability has been discovered in Google Chromium that affects all recent versions of Electron. Any Electron app that accesses remote content is vulnerable to this exploit, regardless of whether the [sandbox option](https://electron.atom.io/docs/api/sandbox-option) is enabled.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free