En resumen
- CVE-2017-16355 es una vulnerabilidad MEDIO (CVSS 4.7) que afecta a passenger, passenger (phusion).
- Probabilidad de explotación en los próximos 30 días (EPSS): 0.36%, mayor que el 29.9% de las vulnerabilidades.
- Solución: actualizar a 5.1.11, 5.1.10 o posterior.
| Package | Affected versions | Patched versions |
|---|
| passenger RubyGems | < 5.1.11
| 5.1.11
|
| passenger | ≥ 5.0.10, < 5.1.10≥ 5.0.10, < 5.1.11
| 5.1.105.1.11
|
Description
In agent/Core/SpawningKit/Spawner.h in Phusion Passenger 5.1.10 (fixed in Passenger Open Source 5.1.11 and Passenger Enterprise 5.1.10), if Passenger is running as root, it is possible to list the contents of arbitrary files on a system by symlinking a file named REVISION from the application root folder to a file of choice and querying passenger-status --show=xml.
NVD description
In agent/Core/SpawningKit/Spawner.h in Phusion Passenger 5.1.10 (fixed in Passenger Open Source 5.1.11 and Passenger Enterprise 5.1.10), if Passenger is running as root, it is possible to list the contents of arbitrary files on a system by symlinking a file named REVISION from the application root folder to a file of choice and querying passenger-status --show=xml.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free